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1 Introduction 
METERTOOL for Kamstrup kWh meter is a tool intended for technicians and laboratories to 
change configurations of meters. It can also be used as backup in communication networks 
to read out data.  

With METERTOOL for Kamstrup kWh meter it is possible to configure and read out electricity 
meters type 382 BCDE,J,K and L, 382 DIN, 162 BCDE,J,K and L and 351B. 

1.1 Log of changes 
Revision Date Change 
F1 2011-11-18 The revision of this manual is compatible with Metertool 

revision S1. 
Setting for GSM use of Metertool implemented. 
KMP / DLMS addressing implemented. 
Period plan for generation L meters implemented. 

   
 

1.2 System requirements 
• METERTOOL for Kamstrup kWh meter is developed to be used with Windows 2000 

Professional (service pack 3), Windows XP (service pack 2), Windows Vista and 
Windows 7. 

• The program requires minimum 55 MB of free space on the PC’s hard disk.  

• The browser Internet Explorer 5.01 or newer must be installed on the PC. 

• To facilitate configuration of Kamstrup meters, a serial data connection (COM port or 
USB port) between the electricity meter and the PC is used. 

• Tree hardware communication options are available: 

o An optical head type 6699-102 can be used for the COM port (sub-9 
connector). 

o An optical head type 6699-099 can be used for USB port. 

o A data/pulse module (6850-003) is also available with additional serial wire 
with USB port (6699-098). This can also be delivered as one unit called 
“Metertool kit” (6830-017). Data/pulse module must to be used for 
programming of JJ- code in direct meters and configuration codes in the 
indirect meters. 

• The optical head is placed between the pins on the front of the meter. The cable 
must point downwards ±20°. 

• For use with Kamstrup USB, a driver for USB must be installed. This driver is available on 
a FTP server and can be downloaded for free. See chapter 1.3. 

1.3 Installation 
To ensure that customers always have the latest revision of the METERTOOL software 
available, Kamstrup METERTOOL for kWh meter can be downloaded from a FTP server. 

To download METERTOOL, you need a FTP client program. Kamstrup recommends FileZilla, 
which can be downloaded free of charge from the following homepage:  

http://filezilla-project.org / ”Download FileZilla Client” 
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Figure 1: FileZilla download front page 

After download: Unzip the file and start installation by activating the file “setup.exe”. 

Installation must be run locally (from CD or hard drive) and not from a central storage or USB 
storage. After downloading and installing the FTP client program, log on to the FTP server and 
fill in the shown information. 

  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Host:  
“ftp.kamstrup.dk” 

User name:  
“METERTOOL-EL” 

Password:    
“Kamstrup0905” (changes approx. every 6 months). 

List of METERTOOL 
programs to download. 

Activate “Quick connect” 
to connect to FTP site. 

Figure 2: The FileZilla front screen showing software available for free download 
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To provide the METERTOOL service for all Kamstrup electricity meter types, METERTOOL is 
developed in different variants, which support different meter types and different meter 
generations. Below is shown the list of METERTOOL variants used for the different meter types. 
The different types of software are available on FileZilla. 
       

ICON in Windows METERTOOL 
Type Number Meter Type Meter Type Number 

 6899-107 
351 CT meter (first 
generation) 

 

685-351-X-XX-XXX 
(12 digits in the type 
number) 

 6899-540 

162/382 direct meters 
(until ultimo 2006) 

686-1XX-XX-XX 
685-XXX-XX-XX 
(10 digits in the type 
number) 

 6899-550 
351A CT meter 
(second generation) 

685-351-AX-XX-XXX 
(13 digits in the type 
number) 

 6899-570 

162/382 BCDE, J, K 
and L direct meters. 
 
 
351B CT meter 

686-1XX-XX-XX-XXX 
684-XXX-XX-XX-XXX 
(13 digits in the type 
number) 
 
685-XXX-XX-XX-XXX 
(13 digits in the type 
number) 

Table 1: Different METERTOOL type numbers for different meter types 

1.3.1 Installing from CD-ROM 
Insert the CD-ROM into your CD-ROM/DVD drive. The installation program will start 
automatically. If the program does not start automatically, use Windows Explorer to find the 
CD-ROM /DVD drive and choose the Setup.exe file from the CD-ROM. 

The following support software will also be installed together with the METERTOOL program: 

• .Net framework 2.0 

• Crystal reports for .Net Framework 2.0 

• Windows Installer 3.1 

• SQL Server Compact Edition 

 

1.3.2 Kamstrup USB driver 
The latest version of the USB driver is available on the FTP server as well. 

1.3.3 Contact us 
In case of questions about or problems with the use of the program, please contact: 
 

Kamstrup A/S,  
Division for Electricity,  
Product group 
El-produkt@kamstrup.dk 
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2 Getting started 
The program icon is found in the Start menu.  

Start ⇒ All Programs ⇒ Kamstrup METERTOOL ⇒ kWh Meter 

METERTOOL is ready when the Main menu appears.  

2.1 Language 
As default, the program starts in English language, which can be changed to Danish, 
German, Polish or Swedish. See 3.2.1 Language. 

2.2 Optical head 
The optical head for communication is available in two hardware variants with different order 
numbers: 

• 9 pin COM port:   Optical head type 6699-102.  

• USB port:      Optical head type 6699-099. 

The optical head is placed between the pins on the front of the meter, and the cable must 
point downwards ± 20°.  
 
 
 
 

 

± 20° 

 
Figure 3: Hardware set-up for a laptop with METERTOOL and an optical head 
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2.3 Hardware module  
The hardware set-up can be ordered as a kit or as individual parts with the following part 
numbers: 

• Hardware module:   Hardware module 6850-003.  

• 3-wire USB connector:      3-wire USB interface 6699-098. 

• All-in-one Kit: Module and USB interface 6830-017. 
 

± 20° 

Connections:
62: Brown
63: White
64: Gren

 
Figure 4: Hardware set-up for a laptop with METERTOOL and a data/pulse module  
 
 
 
 
 
  
 
 

2.4 Communication 
Hardware driver for the optical head is available on the FTP server. Before communication 
with the meter can be established, the correct serial port must be selected. See 3.2.2 Serial 
communication settings. 

2.5 Updates 
Configuration database updates for METERTOOL are available when new configurations such 
as display configurations or tariff / period plans are released. The database is updated 
automatically if the PC is connected to the Internet during start-up. When a new update is 
available, the following message is shown during start-up of METERTOOL: 
 

 

 
Click yes to update the database version. 

Figure 5: Configuration database update message 

METERTOOL does not have an “Offline mode”. Therefore, the eye or the module needs to 
be plugged to a meter, and the meter needs to be powered up before the 
communication can be established and METERTOOL can be used. 

Baudrate of 1200 is the maximum when using the module port 
(data/pulse module with USB wire) 
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Current versions of the METERTOOL software and the configuration database can be seen 
from the “About menu”. 

 
 
 
 
 
 
 
 
 
 
 

Program version

Database version 

Figure 6: The”About menu” is shown during MeterTool start-up
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3 Description of METERTOOL functionality 

3.1 Main menu 
The following screen will appear after start-up. At the bottom of the screen, it is possible to 
check if any meters are found by METERTOOL and the communication port used. 
 

 
Figure 7: Main menu indicating the communication status 
 
 

 
 
 

 
Figure 8: Main menu indicating no communication with meter 
 
In the latter case, answer the following questions: 

 
• Is the meter powered up?  
• Is the optical eye or the data/pulse module placed correctly, according to the 

pictures in chapter 2.2 or chapter 2.3?  
• The 6 pins Hardware module must be placed as close to the display as possible. 

Important in 8 pins meters. 
• Is the correct serial port chosen? 

 
METERTOOL cannot be used in “offline” mode, i.e. without being connected to a mains 
supplied meter. 

If no meter is found by METERTOOL, the bottom screen will look like 
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3.2 File menu → Options  

3.2.1 Language 
The language can be chosen from a number of predefined languages. 

  
Figure 9: Menu for changing the user language 

Changes are saved, and the window closes. METERTOOL needs to be restarted before the 
change takes effect. 

3.2.2 Serial communication settings 

 
Figure 10: Menu for changing the communication settings 

3.2.2.1 Serial Port 

Select the Serial Port to which the communication media is connected. Only available ports 
are shown. It is not possible to communicate with the meter unless the correct Password is 
entered. The default password is “12345”. 

Normally, the Baud Rate can be 9600 for J and later generation meters. For BCDE generation 
meters, the baud rate must be 1200. Be aware of the maximum of 1200 when using the 
module port. 
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Normally, there is no need for changing the factory settings for Timeout and Retries. However, 
if problems occur during the communication with the meter, the problem might be solved by 
increasing “Timeout (ms)”.  

Settings are only active when the “Save” button is clicked and the window closes 
automatically. 

3.2.2.2 GSM 
Selecting GSM makes it possible to have a point to point (p2p) communication with a meter 
with build in GSM. The GSM in the meter must be transparent, not logger. At a serial port of the 
computer a Master modem must be installed. 
 

 
Figure 11: GSM settings 
 
When pressing “Save” a new menu opens in the bottom right corner. 
 

 
Figure 12: GSM phone number entry 
 
Then it is possible to enter the phone number of the GSM meter you would like to connect to. 
When connected to a meter this is indicated in the bottom with signal strength of both the 
Master modem and the GSM meter. 
 

 
Figure 13: GSM signal strength 
 
To have a good communication the signal strength must be equal or above level = 12. 
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The Master modem must have the following settings: 
• Be able to keep the GSM connection even if the COM port is closed. 

 
The following is a list of modems tested together with METERTOOL: 

• Wavecom M106B 
• GT863-PY 

 
As mentioned earlier the GSM modem mounted in the meter must be configured as 
transparent. 

3.2.2.3 TCP/IP 
Selecting TCP/IP makes it possible to communicate with an IP module connected via a LAN 
cable or with GPRS. 

 
Figure 14: TCP/IP settings 

3.2.3 Change Password 
It is possible to change the Password in the meter from the default “12345” to another value 
between “00000” and “65535”. 
 

 
Figure 15: Password change! 
 
 

 
If the password is changed there is NO Fallback.  
So it is very important that the Password is know by the user. 
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3.3 View menu 
In the View menu, it is possible to read out different kinds of meter data and to get a visual 
view of the load profile. 

 
Figure 16: The View menu 

3.3.1 View → Read Logger 
METERTOOL offers a list of different loggers, which can be read out on the screen and 
following be either printed in a report or saved in the METERTOOL database for further use.  

 
Figure 17: The Read Logger menu 
 
In the menu bar, only the loggers are shown that are available in the specific meter type. The 
following description clarifies which loggers are available for which meter types. 

• Cut-off Events: Captures all connect/disconnect events, e.g. Power disable, Relays 
released and Power enable (only available for meters with disconnect function). 

• Debiting Events: Captures a number of predefined registered values for: Energy, 
energy types, tariffs, max power, RTC time for max power and accumulated max 
power. See the complete list in the meter data sheet. The capture interval can be 
configured to different periods as explained in section 3.4.5. 

• CT meter, Debiting events: Differs slightly from the above regarding the energy 
registers (only available in 351B). 

• Debiting logger2 Events: Captures 5 predefined registers (hour counter, A14, R12, A14 
Tariff 1, A+ Tariff2) with the defined time interval for debiting logger 2, which can be 
daily, weekly or monthly. See also section 3.4.7 (only available in direct meter from 
generation K and 351B). 

• Load Profile Events: Energy and energy types logged with the defined load profile 
integration period, sometimes also called log interval (only available in from meter 
generation J and future generation). 

• CT meter, Load Profile Events: Differs slightly from the above regarding the energy 
registers (only available in 351B). 

• Real-time Clock Events: Captures all adjustments of the Real-time Clock. 

• Status Events: Captures tamper detection, magnetic influence and minor internal 
errors inside the meter with timestamp. 
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• Transformer Ratio Events: Captures every change in the transformer ratio number (only 
available in 351B). 

• Voltage Quality Events: Captures with a timestamp when the voltage drops below the 
"Cut-off voltage", or when voltage is beyond the defined "High" and "Low" voltage 
limits for one or more phases. 

• Load profile event logger: Captures with a timestamp every change in the load profile 
logger set-up, e.g. changes in the integration period or the number of energy types 
(only available in meter generation K). 

• Analysis log Events: Captures the values of a number of defined registers with a 
configurable log interval. The log interval can be set independent of the log interval 
of the load profile logger (only available in direct meter from generation K). 

• Neutral fault log Events: Captures if neutral fault is detected (only available in meter 
generation L). 

 

 

In 3.3.3 View → Reports, it is explained in details how to read out different logs, print them to 
METERTOOL-screen (using reports) or to store the log data in the METERTOOL database.  

 

 
 

Figure 18: An example of a read out of load profile for a two-quadrant (A+ and A-) meter 

By clicking the “Save” button, the log is stored in the METERTOOL database and is available 
for a load profile.  

By clicking the “Report…” button, the file is also saved, and in addition a report is generated 
and shown on the screen. 
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3.3.2 View → Read Meter Data 
Registers are selected in the left column by drag and drop or by the arrow buttons. 

 
Figure 19: Menu for selectable Read Meter Data 

3.3.2.1 Register list Profiles 

A customized list of register values can be saved as a profile in the METERTOOL database and 
will be permanently available for future use. Just write a name for the profile and click the 
“Save” button when the required registers are listed. Earlier saved profiles will be shown on the 
list and can be opened by clicking the “Load” button.  

Values on the selected register list are updated on every click on the “Read meter” button. If 
the two tabs “Save register values” and “Save configuration” are checked (as default), the 
selected register values and meter configuration are saved in the METERTOOL database. 

3.3.3 View → Reports 
Data in the METERTOOL database can be viewed and printed or saved in different file 
formats and exported to other programs by choosing View → Reports → Events.  
Every logger described in 3.3.1 View → Read Logger is available for the report functionality. 
 

 
Figure 20: Available loggers for the Report view 
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In the group tree in the left pane of the screen, all logger reports stored in the METERTOOL 
database are shown. The reports are sorted in order of serial number and secondary in order 
of time. It is also possible to save the log data in a .csv file. 
 

 
Figure 21: An example of a Report view 
 
By selecting View → Reports → Configuration changes, it is possible to see a report of all 
done changes in the meter configuration.  

3.3.4 View → Meter Load Profile 
In the upper left corner, you can choose between all meters (serial numbers) from which the 
load profile logger is read out and saved in the database. Depending on the meter type, the 
different energy types can be shown. 

 
Figure 22: An example of a Meter Load Profile view. 

By marking a specific area on the graph, it is possible to view only the marked area of the log 
on the screen. When clicking the “Zoom all” button, the full log is again shown on the screen.   
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Figure 23: A zoomed part of the Meter Load Profile view.  
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3.4 Configuration menu 
This section explains the different configuration options for the meter. 

 
Figure 24: The Configuration menu 
 

3.4.1 Metertool behavior 
As this Metertool is used for different generations of direct meters as well as the CT meter 
351B, you will see by using the program that depending of which meter type the tool is used 
on some of the “menus” are dimmed out. This is because this “menu” is not valid for the meter 
type connected to the Metertool. Below is shown how Figure 24 will look if the Analysis Logger 
is not valid.  
 

 
Figure 25: The Configuration menu (Analysis Logger dimmed out) 
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3.4.2 Configuration → Display Settings 
After selecting the Display Settings menu, click the “Read” button to see the current display 
settings for the meter. It is possible to switch between “Manual”, “Automatic” and “Battery” 
scroll.  

 
Figure 26: Settings for display configuration 

3.4.2.1 User-defined display configurations 

User-defined display configurations can be made by adding registers to or removing registers 
from the “Selected” window by drag and drop or by the arrow buttons. Registers for total 
energy (1, 2, 3 or 4 dependent on meter type) are mandatory and cannot be deleted. The 
order of selected registers is changed by arrow up and arrow down. 

3.4.2.2 Options 

Preceding zeroes (in front of energy register values) and OBIS information (in the upper left 
corner) will be shown when these two fields are checked. 

3.4.2.3 Display Presets  

From the roll-down menu, it is possible to select one of the Kamstrup predefined display 
configurations. The field shows either the display (FFF) code or “999 User-defined” if the 
display configuration is different from one of the predefined settings. Clicking “Save As…” will 
save such a User-defined display configuration and clicking “Load File…” will open a 
previously saved User-defined display configuration. Changes only take effect when the 
“Program” button is clicked. The display settings can also be changed via the configuration 
numbers explained in 3.4.5 Configuration → Configuration Numbers. 
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3.4.3 Configuration → JJ Smart Disconnect 
The smart disconnect option is available for 162, 282, 382 generation J and following 
generations with integrated breakers. The option is also available for 351B meters, but the 
menu is slightly different for the two meter types as shown in Figure 27 and Figure 28.  

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

• Cut-off Basis: The disconnect functionality is selected by marking “Load controlled 
cutoff” and/or “Prepayment” (“Prepayment” is not available for 351B). At the same 
time, it is necessary to choose whether the functionality is regarding power or current. 

• Switching On: Select if the switching on after disconnection is to be done 
automatically or manually. 

• Delay: The parameters are relevant for delays in the disconnect functionality, allowing 
time-limited periods of power exceeding the cut-off value.  

• Ishortcircuit: Defines the current above which the disconnect functions is disabled in 
order to protect the relays. 

• Tconnectwait: The time from disconnection until a re-connect is possible. The minimum 
time is 60 seconds. 

• Tprepaymentlowmax: The numbers of days after the prepayment value reaches 0, 
until the meter finally cuts off. In the meantime, only a minimum load equal to the 
Pexeption value is acceptable. This is described in 3.4.5.3 Configuration variables. If 
this value is exceeded, the meter disconnects immediately.   

 

The Smart Disconnect user-defined settings can be saved and programmed to the meter in a 
similar way as with the tariff- / period-plan settings, which is exemplified in 3.5.7. 

Figure 28: Smart Disconnect menu for 351B Figure 27: Smart Disconnect menu for 162 and 382 

JJ Smart Disconnect settings can only be changed via the module 
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3.4.4 Configuration → Analysis Logger 
The analysis logger is available for 162, 282 and 382 generation K and following generations. 
Click the “Read” button to see the current settings for the analysis logger.  

 
Figure 29: Settings for Analysis Logger 

 

Be aware that the log depth depends on the meter type (1, 2 or 4 quadrants), the log interval 
of the load profile logger (i.e. Load profile period, configuration code E) and the number of 
registers and log intervals of the analysis logger.  

3.4.4.1 Change analysis logger 
The following options are possible for the analysis logger: 

• To add more registers, click the up-arrow for the number of registers, and select 
afterwards the registers to be logged from the list of predefined registers. Only the 
predefined registers are selectable. 

• To remove registers, click the corresponding down-arrow. Please be aware that 
decreasing the number of registers will remove the registers from the bottom of the list. 

• The log interval can also be configured with a number of predefined period values. 

• The changes will not take effect before the “program” button is clicked and the 
downloading is executed.  

 

 

 

 

All existing analysis logger data will be deleted when a new configuration for 
the analysis logger is programmed to the meter. 
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3.4.5 Configuration → Configuration Numbers 
After selecting the Configuration Numbers menu, click the “Read” button to see the current 
configuration settings for the meter. 

 
Figure 30: Settings for configuration numbers 

 

Changes can be made by means of the drop-down menus or by entering new values. New 
and changed profiles can be named and saved as a profile. 

3.4.5.1 Transformer ratio 
For CT meters, the transformer ratio is also available in the configuration settings as an 
additional line in the full list as shown in Figure 31. 
 

 
Figure 31: Additional configuration settings for transformer ratio. 
 
  
 
 
 

3.4.5.2 User-defined Files 

User-defined Display configurations, Smart Disconnect, Tariff / Period control tables and 
Daylight saving tables (FFF, JJ, OOO and PPP-codes), which are saved on a local drive, can 

The SSS-code (transformer ratio) can only be changed via the module port, and 
only if the meter is unlocked for this feature. 
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be opened by selecting “999: User Defined” in the drop-down menu. See also 3.5.7 for an 
example on how to generate a customized tariff plan and download it to the meter. 

3.4.5.3 Configuration variables 

The page with additional configuration variables contains some specific configuration data 
that are not part of the configuration numbers just described. Click the “Read” button to see 
the current settings. 

The notification in brackets (e.g. V1, V2, V3, etc.) refers to the order configuration. If the 
values are changed, the changes will not take effect before the “Program” button is clicked. 

 
Figure 32: The configuration variables which are not part of the configuration numbers 
 
In the following, the different variables on the screen are described shortly.  

 

- Meter number: This number is normally equal to the customer number on the meters 
front label. As default the number is equal to the serial number, but can be 
customized in the order configuration.  

- Meter number prefix: Used for customer specific purposes when a prefix is wanted. 

- Special data 1: Customer specific value. Could be anything that a company found 
useful, e.g. a phone number for service purposes. 

- Special data 2: Customer specific value. Same function as Special data 2. 

- MBUS communication address: This value is used as the M-Bus address when the meter 
is used with a wired M-Bus module. The value is 254 as default, but can be set to the 
range between 0 and 254. Is also configurable in the order configuration (V3). 
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- KMP communication address: This value is used for changing the KMP address when 
using RS-485 modules (multi drop). The value is 63 (3F in hex) as default, but can be set 
to the range between 0 and 63 (0 and 3F in hex). 

- DLMS address: This value is used for changing the DLMS address when using RS-485 
module (multi drop).  The value is 32 (20 in hex) as default, but can be set to the range 
between 16 and 125 (10 and 7D in hex). 

- Pulse output constant: Specifies the number of output pulses for every kWh consumed. 

- Pulse input constant: Specifies a reciprocal scale factor of the input pulses. The range 
of the value is 0.1 to 1000, i.e. a power scaling of 10 to 0.001.   

- Pulse input value: This value can be set if the input source (e.g. the water meter) has 
an offset (pre-consumption) when it is connected to the electricity meter. 

- Power threshold: Every time the actual power exceeds this threshold value, the power 
threshold counter adds one to its register value. 

- Pdisconnect: Only relevant to meters with disconnect function. Specifies the limit for 
the breakers to disconnect the power to the installation. 

- Pexception: Only relevant to meters with disconnect and prepayment functions. Sets 
the maximum allowable power/current when the power has been re-connected after 
a power disconnect due to the prepayment register reaching 0. Will normally be set 
as the minimum requirements for consumption in a house installation.  

- A14prepayment kWh read: The current value for the prepayment register. The 
prepayment value is read-only with METERTOOL. 

 

3.4.6 Configuration → Voltage Quality Event Parameters 

 
Figure 33: The settings for voltage quality events 

New settings are not active before the “Program” button is clicked. 

Parameters:  Range: 
Under Voltage 230V – (0 – 20 %) 
Over Voltage 230V + (0 – 20 %)  
Min. Duration 10…2550 secs. 
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3.4.7 Configuration → Debiting Logger 2  
The debiting logger 2 is available for 162 and 382 generation K and following generations. The 
debiting logger 2 is also available for 351B.  

 
Figure 34: Settings for debiting logger 2 

New settings are not active before the “Set Log interval” button is clicked. 

 

Configurable log intervals 
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3.5 Tools Menu 
Finally, METERTOOL contains some additional tools for configuration, read-out and control of 
the meter. These options are available in the Tools menu.  
 

 
Figure 35: Tools menu 
 

3.5.1 Tools Menu → Change Tariff 
This option allows the user to manually change the tariff immediately. The current tariff is 
shown by clicking the “Read tariff” button. All tariffs from 1 to 8 can be set.  

This can be used in laboratory for checking that the meter is calculating energy in the right 
tariff. 

 
Figure 36: Change Tariff menu 

If the meter uses a defined tariff plan, a Change Tariff request will overrule the plan, but at 
next tariff shift (every 15 min.), the tariff plan will again have highest priority. 
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3.5.2 Tools Menu → Verification 
This option allows the user to change the display mode from operation mode to verification 
mode. In operation mode, the energy registers are shown with the configured resolution, i.e. 
[7.0] or [6.1]. 

  

 
Figure 37: Settings for the verification 
 
The verification mode is selected simply by selecting one or more of the four verification 
registers. When one register is selected, the value is shown in the display with the [3.4] 
resolution.  

If more than one register is selected, you can switch between the registers by pushing the 
button on the meter front panel. The meter returns to Operation mode if the push button has 
not been activated for 16 hours. 

With METERTOOL, you can return to operation mode by clicking the Operation mode tab on 
the Verification menu. 
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3.5.3 Tools Menu → Daylight Saving 
It is possible to set the Daylight saving plan for the clock in the meter. The current daylight 
saving plan in the meter is shown by clicking the “Read meter” button. The European daylight 
saving plan is predefined in METERTOOL and can be selected by clicking the “EU Plan” 
button.  

 
Figure 38: Daylight saving plan 

The way to create, save and download a customized daylight saving plan is similar to the 
way to change the tariff plan as explained in 3.5.7. 
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3.5.4 Tools Menu → Power control 
This option is only available for meters with integrated breakers and allows the user to control 
the breakers directly independent of any smart disconnect settings.  

 
Figure 39: Power enabled 

 

When clicking the “Cut Power” button, the breakers disconnect. This is also indicated with a 
red LED on the meter front panel. 

 
Figure 40: Power disabled 

 

When clicking the “Enable” button again, the breakers/relays will be released, and 
afterwards, they will be enabled again.  

 
Figure 41: Breaker/relays are released 
 
Every time the status has been changed, the power control is locked for 1 minute to avoid 
rapidly on-off control of the breakers. 
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3.5.5 Tools Menu → IEC1107 request 
IEC1107 is available for 162 and 382 meters generation BCDE and for generation J, software 
revision L1 and newer software versions, and generation K and never generations.  

 
Figure 42: IEC1107 Read-out view for 162 and 382 meters 

 

IEC1107 is also available for 351B.   

 

 
Figure 43: IEC1107 Read-out view for 351B meters 
 
Only the values shown in Figure 42 and Figure 43 are available in the IEC1107 read-out. 
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3.5.6 Tools menu → Tariff Plan 
METERTOOL offers the possibility of defining a customized tariff plan 25 years ahead. The tariff 
table can be created on three different levels: 

Season plan level: It is possible to define a summer/winter calendar for each year in the plan. 
See Figure 44: The tariff plan on the season plan level where the green area indicates the 
summer plan and the white area the winter plan. By clicking on a certain date, it can be set 
to either a new start date or a new end date for the (green) summer plan. The season plan 
must not be seen as the daylight saving plan, even though it is possible to select the EU 
daylight saving plan as the summer/winter plan. The daylight saving plan must be configured 
separately, as explained in 3.5.3 Tools Menu → Daylight Saving 

• Holiday plan level: Holidays and national holidays can be defined separately from 
one year to another. Clicking on a specific day will change the color to green and 
the day will be seen as a holiday in the tariff plan. Sundays are automatically 
considered as holidays.  

• Day plan level: 8 different tariffs can be set during the day and can be defined with a 
resolution of 15 minutes. The tariff plan operates with weekdays, Saturdays and 
holidays.  

A tariff plan can be defined 25 years ahead from present time. When a tariff plan is created, 
it can be saved, and by using the Configurations Number menu, it is possible to download 
the tariff plan to the meter. 

In the following section, it is exemplified how you can create your own customized tariff table, 
saved in a file and finally downloaded to the meter for use in tariff control metering. 

 
Figure 44: The tariff plan on the season plan level 
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Figure 45: Tariff plan on the holiday plan level  
 
 
 
 

 
 
Figure 46: Tariff plan on the daily plan level 
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3.5.7 Example: How to create, save and download a customized tariff table 
The following five-step procedure explains in details how to change the tariff plan in the 
meter to a customized plan also created with METERTOOL. 
 

1. When the tariff plan is made according to the explanation in the previous section, the 
plan must be saved on the user’s local laptop drive in .xlm format. 

2. Open the menu “Configuration → Configuration Numbers” and click the “Read” 
button.  

3. Set the “OOO”-code: “Tariff control tables” to “999: User-defined”. 

 

 
 

4. Open the file for the saved tariff plan in the User-Defined Files field.  

 

 

 

 

 

5. Click the “Program” button to download the tariff plan to the meter. 

 

The sequence is similar for the three other User-defined Files, i.e. FFF-, JJ- and PPP-codes. 

3.5.8 Tools Menu → Period Plan 
In 162 and 382 of the generation L, the Tariff Plan is replaced by a Period Plan. The reason for 
this is that the behavior of the two plans is different.  
In generation L meters it is possible not only to control the tariffs but also to control two load 
outputs. Therefore you can consider the tariff plans as divided into tree independently plans. 
 
Before making a plan, different things has to be considered: 

- Working days – Non working days 
- Period change time (often the same as summer time – normal time, now called Period 

A and Period B. This with a resolution of 1 minute) 
- Tariff changes (up to 8 changes per day is possible. This with a resolution of 1 minute) 
- Exception days (previous called holydays) 
- Load control 1 
- Load control 2 

 
Below and on the next pages is shown an example of a plan.  
 
Making your own plan and store it in a meter is done the same way as in 3.5.7. 
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Figure 47: Working days - Non Working days 
 
 
 

 
Figure 48: Period change time 
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Figure 49: Exception days 
 

 
Figure 50: Load control 1 
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Figure 51: Load control 2 
 
The Tariff plan layout looks equal as the Load control plans. 
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3.5.9 Tools Menu → Set time 
The current Real-Time Clock in the meter is shown by clicking the “Read Clock” button.  

The RTC can be set to the PC clock or a customized clock. It is also possible to set a specific 
time zone. 

 
Figure 52: Settings for the Real-Time Clock 
 
 
 
 
 
 
 

3.5.10 Tools Menu → AddPrepayment 
It is possible with Metertool to add some extra kWh for meters used as prepayment meters. 
In Figure 53 3 kWh is added to a meter. 
 

 
Figure 53: AddPrepayment 
 
 

Note that most laptops automatically follow winter/summer time, which is not 
necessarily the case in AMR systems.   

Add Prepayment can only be done via the module port
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3.5.11 Tools Menu → Neutral fault setup 
In 382 generation L there is a neutral fault logger. Meters with breakers can be configured to 
switch off the supply when a logging occurs.  
Both this and the other settings can be done with Metertool. 

 
Figure 54: Neutral fault setup 
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